PapyClic - Design

PapyClic - Design

menu latéral avec onglets

6 appréciations
Hors-ligne
Bonjour
J'ai mis un bloc onglets dans le menu latéral et j'ai un article avec onglets.
lorsque j'ai fait le bloc onglets dans le menu celui de l'article ne fonctionne plus.
les codes css et html du bloc et de l'article sont bien en place.

Merci de ta réponse.
http://labodesimon.blog4ever.com/
Simon

67 appréciations
Hors-ligne
Simon,

J'ai testé sur mon blog, regardes l'article >>> [lien]
tout fonctionne bien.
J'ai même fait un tes avec ton CSS, je ne l'ai pas laissé, mais si tu es libre je le mets rapidement.

Soit c'est un problème avec myDesign, je vais faire un test dans la journée.
Soit dans ton CSS il y a une interférence, j'ai regardé mais pas trouvé.

J'attends ta réponse pour mettre ton CSS sur mon bloc.



6 appréciations
Hors-ligne
Ok Pierre tu peux y aller.
Désolé mais j'ai du m'absenter.
Simon

67 appréciations
Hors-ligne
...

Tu peux voir l'article >>> [lien]
Tu vas voir que les 2 menus onglets fonctionnent bien.


Mais je en parallèle je fais un essai sur un autre blog mais en myDesign.
Je te tiendrai au courant.


6 appréciations
Hors-ligne
OK

Merci
Simon

67 appréciations
Hors-ligne
...
Tu as vu sur ce blog, je vais donc supprimer cet article.

Je reprends la recherche sur un autre blog, mais il me faut un peu de temps, je te recontacte.


6 appréciations
Hors-ligne
Pas de soucis je vais retourner dans ma gestion

@+
Simon

6 appréciations
Hors-ligne
Simon

67 appréciations
Hors-ligne
...
Dans quelle partie ?

6 appréciations
Hors-ligne
j'ai remis le code et ça ne fonctionne plus.
<p> </p><p> </p>
<div id="mntab_menu-1">
<ul class="tabs">
<li><a href="#tabs-1">Bloc1</a></li>
<li><a href="#tabs-2">Bloc2</a></li>
<li><a href="#tabs-3">Bloc3</a></li>
<li><a href="#tabs-4">Bloc4</a></li>
</ul>
<div class="tab_container">
<div id="tabs-1" class="tab_content">
<h3>Menu</h3>
<ul>
<li><a href="http://dizperso2-labs.blog4ever.com/generateur-menu-onglets-dans-menu-lateral"></a></li>
<li><a href="http://labodesimon.blog4ever.com/la-pluie">La pluie</a></li>
<li><a href="URL du lien">texte lien</a></li>
</ul>
<p> </p>
</div>
<div id="tabs-2" class="tab_content">
<h3>Divers</h3>
<ul>
<li><a href="URL du lien">texte lien</a></li>
<li><a href="URL du lien">texte lien</a></li>
<li><a href="URL du lien">texte lien</a></li>
</ul>
<p> </p>
</div>
<div id="tabs-3" class="tab_content">
<h3>Tests</h3>
<ul>
<li><a href="URL du lien">texte lien</a></li>
<li><a href="URL du lien">texte lien</a></li>
<li><a href="URL du lien">texte lien</a></li>
</ul>
<p> </p>
</div>
<div id="tabs-4" class="tab_content">
<h3>images</h3>
<ul>
<li><a href="URL du lien">texte lien</a></li>
<li><a href="URL du lien">texte lien</a></li>
<li><a href="URL du lien">texte lien</a></li>
</ul>
<p> </p>
</div>
</div>
</div>

Simon

6 appréciations
Hors-ligne
Dans la structure html

Si je supprime le bloc du menu latéral l'onglet article fonctionne.
Simon

67 appréciations
Hors-ligne
...
Je suis sur mon autre blog pour tester.

Théoriquement ça fonctionnait bien en Dizperso2.

J'ai le problème iverse, avec DP2 mais le menu onglets mis dans la structure HTML
L'article fonctionne bien et pas le bloc menu ... bizarre !!!



6 appréciations
Hors-ligne
Simon

67 appréciations
Hors-ligne
...
Ton autre blog est également en myDesign et DP2.

J'ai tellement bidouillé que je pense avoir fait une modification qu'il ne fallait pas faire, les 2, bloc et article, restent déplié ... bizarre !!!
Je vais abandonner pour l'instant et je reprendrai dans la soirée, j'aurai les idées plus claires.

On se tient au courant.

6 appréciations
Hors-ligne
OK
Parfois c'est mieux de laisser refroidir la machine.

Moi aussi j'avais fait des erreurs avec le menu figé.
souvent on copie et il manque un bout de code.
@+
Simon

6 appréciations
Hors-ligne
Pierre

Rien de nouveau sur le problème de faire un onglet latéral et un en article ?

Autre question:
Si on veut 2 menus onglets en latéral ( les miens sont dans la structure) il faut ajouter un autre code ? ou faire une modif de code ? http://labodesimon.blog4ever.com/

Bonne journée Pierre
Simon

67 appréciations
Hors-ligne
Simon,

Rien de nouveau, sur mon blog ça fonctionne bien, j'ai un menu onglet dans le menu latéral et j'ai des articles avec onglets.

Le principe est une question d'ID à respecter, chaque menu doit-être identifié différemment.

Pour mettre 2 menus avec onglets dans le menu latéral
- dans le HTML mettre 2 IDs différentes :

mntab_menu-1
mntab_menu-2
Et il faut également un script pour chacun en mettant l'ID correspondante.

Pour les articles avec onglets, les IDs doivent être différentes de celles du menu latéral
#menuTab-1
et si tu veux en mettre plusieurs dans lemême article, il faut mettre des id différentes
#menuTab-2
#menuTab-3
et pour chacun faire un script diffférent avec les IDs correspondantes.

Il faudrait faire un script qui puisse servir à plusieurs menus ... à suivre.



67 appréciations
Hors-ligne
...
Je me suis permis de tester sur ton blog, j'ai trouvé une solution en plus de ce qu j'ai écris dans mon précédent message.

Il faut nommer les blocs contenu différemment, pour le premier menu tu peux laisser comme c'est, mais pour les menus suivants, par exemple le menu bis :
#tab21
#tab22
#tab23
#tab24
etc...

Puis situ as un troisième menu :
#tab31
#tab32
#tab33
#tab34
etc...

C'est la solution pour l'instant, à l'occasion je chercherai peut-être une autre solution. Certainement ça sera la même solution dans le cas de plusieurs blocs avec onglets dans un même article.

Regarde le CSS là aussi il faut faire des modifes, il y a certainement mieux à faire mais dans la présentation actuelle c'est la solution.
On peut faire les 2 blocs de couleur différente en créant des règles pour chacun.


6 appréciations
Hors-ligne
.......

Merci pour les modifs.
<div id="mntab_menu-1"> en fait, on nomme le menu -1 et menu-2 ect....et on saute de dizaine pour la suite du code.
<li><a href="#tabs-21">Jan</a></li>
Idem pour le css mais c'est vrai qu'on pourrait faire 2 CSS et changer les couleurs et/ou le style.
Pour le script dans la bordure en effet il faut en faire un autre .( vu)
_____________________
Je ne sais pas pourquoi les onglets dans mon article ne fonctionne pas.
Je vais revoir le code de l'article pour voir s'il n'y a pas problème.





Dernière modification le dimanche 28 Septembre 2014 à 19:59:03
Simon

67 appréciations
Hors-ligne
Simon,
Pour le bloc onglets dans l'article, tu renommes les blocs contenu, par exemple :
#tab-101
#tab-102
#tab-103
#tab-104
etc ...



6 appréciations
Hors-ligne
............
J'ai renommé dans le html et tout fonctionne pour l'article.
Le css de l'article peut varier lui aussi si on écrit un menu tab 3 puis 4 etc et idem pour le script.
Voir l'article qui ne fonctionnait pas: http://labodesimon.blog4ever.com/les-onglets-1#tabs-104

Encore merci et bonne soirée.
Simon

67 appréciations
Hors-ligne
...
ça fonctionne mais ce qu'il faut essayer c'est faire un article avec onglets et les menus latéraux, pour voir si tout fonctionne.


6 appréciations
Hors-ligne
Mais j'ai les deux et ça fonctionne.


2 onglets dans le menu latéral ( par la structure ) et 1 onglet dans un article.

http://labodesimon.blog4ever.com/

Dernière modification le dimanche 28 Septembre 2014 à 22:06:56
Simon

67 appréciations
Hors-ligne
...
Non ton article est pleine page;
Il faut un article avec les menus sur les côtés pour voir si les onglets fonctionnent au centre et également dans le menu.


67 appréciations
Hors-ligne
...
Comme mon article >>> [lien]

6 appréciations
Hors-ligne
........
J'ai enlevé la pleine page et c'est bon.
les onglets fonctionnent tous.
Simon

67 appréciations
Hors-ligne
...
Super !


6 appréciations
Hors-ligne
...............
Simon

Répondre
Pseudo :
Adresse e-mail:


Se souvenir de mes infos ( pseudo et e-mail ) :
Cochez la case ci-contre :

Inscrivez-vous au blog

Soyez prévenu par email des prochaines mises à jour

Rejoignez les 159 autres membres